Back to overview
Resolved

Resolved — Tracking

Sep 26, 2026 at 5:40pm UTC
Affected services
Tracking

Resolved
Sep 26, 2026 at 5:40pm UTC

Tracking lookups and delivery status updates have returned to normal.